Between May 28, 2026, at 15:30 UTC and May 29, 2026, at 03:30 UTC, our platform experienced an email delivery outage. During this 12-hour period, system-generated emails were not successfully delivered.
Posted May 29, 2026 - 15:02 UTC
Resolved
This incident has been resolved.
Posted May 29, 2026 - 03:45 UTC
Identified
The issue has been identified, and the solution is under work.